Video Playback Issues

Incident Report for Medmastery

Resolved

This incident has been resolved.
Posted 3 days ago. Apr 02, 2025 - 18:28 UTC

Monitoring

We're currently experiencing intermittent issues with video playback due to an ongoing problem with our video provider. This may impact the ability to start or smoothly watch some video lessons. We're closely monitoring the situation on their end and will keep you updated as they work to resolve it. Thank you for your patience and understanding.
Posted 4 days ago. Apr 01, 2025 - 14:50 UTC
This incident affected: Website and Learning App.